Напишите программу, которую вводит два вещественных числа, x и y, и вычисляет значение

0 голосов
433 просмотров

Напишите программу, которую вводит два вещественных числа, x и y, и вычисляет значение
x {}^y


Информатика (37 баллов) | 433 просмотров
0

(double x, double y) => Math.Pow(x,y);

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите x и y через пробел:');
  Writeln(x**y)
end.

Примеры
Введите x и y через пробел: 2 20
1048576

Введите x и y через пробел: -2 20
1048576

Введите x и y через пробел: -2 19
-524288

Введите x и y через пробел: -0.7 19
-0.00113988951853731

Введите x и y через пробел: 3 -5
0.00411522633744856

Введите x и y через пробел: -3.5 -2.4
NaN

В последнем примере NaN - "Not a Number" (не число).
(150k баллов)
0

а на c#