Написать программу каторая вазводит в квадрат нечетное число и делит ** 2 четное

0 голосов
42 просмотров

Написать программу каторая вазводит в квадрат нечетное число и делит на 2 четное


Информатика (22 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

Окей, я так понял число вводится пользователем?
с++:
#include
using namespace std;

void main()
{
     int n;
     cin >> n;
     if (n%2==0)n/=2;
     else n=n*n*n;
     cout << n;<br>     cin.get();
     cin.get();
}

(1.5k баллов)