Помогите написать программу ** C++

0 голосов
20 просмотров

Помогите написать программу на C++


image

Информатика (1.1k баллов) | 20 просмотров
0

В массиве*

0

почему скрином? скиньте текстом, так сложно переписать?

0

Я сам набираю на worde, у нас очень умные люди, которые начинают забивать в gogle все задания и по поиску попадают сюда на эти решения( и выходит казус) :D Кто у кого списал :D Поэтому все задания выкладываю скрином :3

0

Вот моё решение.

0

#include #include #include using namespace std;int main(){ srand(time(NULL)); const int size=15; int a[size]; cout << "Your array." << endl; for (int i=0;i<size;i++) { a[i]=rand()%100; cout << a[i] << " "; } int k5=0; int k30=0; for (int i=0;i<size;i++) { if (a[i]%5==0) k5++; if (a[i]>30) k30++; } cout << "\nBolshe chem 30 = " << k30 << endl; cout << "Kratnoe 5 = " << k5 << endl; cin.get(); cin.get(); return 0;}

Дано ответов: 2
0 голосов
Правильный ответ

Если бы надо было сделать через вектор, а не обычный массив, было бы ещё проще.
#include
#include
#include
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(1, 100); // диапазон от 1 до 100

int main()
{
int a[15];
int count = 0;
for (auto &i : a) {
i = uid(gen);
cout << i << " ";<br>if (i % 5 == 0 && i > 30) {
count++;
}
}
cout << endl << "Count: " << count;<br>return 0;
}
(4.2k баллов)
0 голосов

#include

using namespace std;

int main()
{
int A[15];

int MasVal = 1;
int counter = 0;

for (int i = 0; i < 15; i++)
{
A[i] = MasVal;
MasVal = MasVal + 1;
}

for (int j = 0; j < 15; j++)
{
if (A[j] % 5 == 0 && A[j] > 30)
counter = counter + 1;
}

cout << " Kolichestvo chisel: " << counter << endl;<br>
return 0;
}

(13.4k баллов)