Задача 1. Написать программу, которая вычисляет среднее арифметическое ненулевых...

0 голосов
71 просмотров

Задача 1.
Написать программу, которая вычисляет среднее арифметическое ненулевых элементов массива А[1..50], элементы которого вычисляются по формуле:
А[i]=sin(i)*cos(i)
Задача 2.
Написать программу, которая проверяет, образуют ли элементы массива K[1..100], введенного с клавиатуры неубывающую последовательность.


Информатика (12 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

Решение для двух данных задач ниже в комментарии

(1.7k баллов)
0

Первая задача

0

-----------------------------

0

program HelloWorld;

var

A : array[1..50] of real;
i, count : integer;
average : real;

begin

average:=0;
count:=0;

for i:=1 to 50 do
begin

A[i]:=sin(i)*cos(i);

if A[i]<>0 then
begin
count:=count+1;
average:=average+A[i];
end;

writeln('A[',i,'] = ',A[i]);
end;

writeln('average = ',average);

end.

0

----------------------------

0

Вторая задача

0

----------------------------

0

program HelloWorld;

var

k : array[1..10] of integer;
o : boolean;
i : integer;

begin

o:= true;

for i:=1 to 10 do read(K[i]);

for i:=1 to 9 do if K[i]>=K[i+1] then o:=false;

writeln(o);

end.