Информатика: магазине продается костюмная ткань. Ее цена В руб. за квадратный метр....

0 голосов
218 просмотров

Информатика: магазине продается костюмная ткань. Ее цена В руб. за квадратный метр. Составьте алгоритм и программу, которая подсчитает и выведет на экран стоимость куска этой ткани длиной Х метров и шириной y метров. Построить математическую модель, блок-схему, написать программу в среде Паскаль.


Информатика (14 баллов) | 218 просмотров
Дан 1 ответ
0 голосов

Для того, чтоб не запутаться :
х-длина куска ткани;
у-его ширина;
S-площадь ткани, которая получится при вводе длины и ширины ткани;
с-цена , которую вы должны получить;
Не пугайтесь, если при цене будет вылетать число*В, т.к. изначально В-данная цена за 1м^2
Приступаем
1) блок-схема (фото)
2) программа
Program (название);
uses crt;
var B,x,y,S,c:real;
begin
writeln('введите длину ткани=');
readln(x);
writeln('введите ширину ткани=');
readln(y);
S:=x*y;
c:=S*B;
writeln('цена за кусок ткани=',c);
end.
3) мат
S=x*y и c(цена)=в(данная цена за 1 м^2)*S


image
(1.7k баллов)