Ребят срочно нужна помощь по программированию. Нужна пятёрка и я получу за четверть пять,...

0 голосов
22 просмотров

Ребят срочно нужна помощь по программированию. Нужна пятёрка и я получу за четверть пять, помогите пожалуйста. Напишите программу в паскале. Имеется одна коробка со сторонами а б с(вводятся с клавиатуры), ещё есть 1 коробка со сторонами x z t(вводятся с клавиатуры). Надо ответить влезит ли первая коробка во вторую если коробки можно вращать.


Информатика (117 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var a,b,c,x,z,t,k: integer;
begin
  write('a b c через пробел:  ');  readln(a,b,c);
  write('x z t через пробел:  ');  readln(x,z,t);
  if a>b then swap(a,b);
  if b>c then swap(b,c);
  if b  if x>z then swap(x,z);
  if z>t then swap(z,t);
  if z  k:=0;
  if a>=x then 
     if (b>=z) and (c>=t) then k:=1;
  if (a<=x) then<br>     if (b<=z) and (c<=t) then k:=1;<br>  if k=1 then writeln('да')
  else writeln('нет');
end.


a b c через пробел:  10 7 3
x z t через пробел:  3 5 9
да

a b c через пробел:  8 5 7
x z t через пробел:  9 7 4
нет


(9.7k баллов)
0

Объясни пожалуйста что такое swap

0

swap(a,b) это обмен значений переменных a:=b; b:= a; чтобы не использовать дополнительную переменную с , иначе c:=a; a:=b; b:=c; - это обмен a и b через переменную с

0

Спасибо твоя программа очень помогла но я её немного поменял. Но всё ровно спасибо!