Написать программу которая выводит ** экран сумму 5 натуральных чисел. Смотреть задание...

0 голосов
34 просмотров

Написать программу которая выводит на экран сумму 5 натуральных чисел. Смотреть задание использовать 3 циклические конструкции


Информатика (34 баллов) | 34 просмотров
0

И где смотреть?

0

Ну вот на это задание . Если было бы что то там какая нибудь таблица я бы скинула , а так вот задание

0

А какие именно натуральные числа, где брать их?

0

Наверное самим придумать

0

Пожалуйста помоги

Дан 1 ответ
0 голосов

Var
  i,s:integer;
 
begin
  s:=0;
  for i:=1 to 5 do s:=s+i;
  Writeln('for: ',s);
  s:=0; i:=1;
  while i<=5 do begin<br>    s:=s+i;
    i:=i+1
    end;
  Writeln('while: ',s);
  s:=0; i:=1;
  repeat
    s:=s+i;
    i:=i+1
  until i>5;
  Writeln('repeat: ',s)
end.

Результат
for: 15
while: 15
repeat: 15

(142k баллов)
0

Это всё

0

Все три циклические конструкции??

0

Да. Три же ответа. Сумма чисел от 1 до 5.

0

Большое спасибо за помощь