Написать программу с помощью языка программирования Паскаль по нахождению ответа **...

0 голосов
34 просмотров

Написать программу с помощью языка программирования Паскаль по нахождению ответа на вопрос: войдет ли круг диаметром D в прямоугольную рамку размером а на b
Составить программу
ПРОСТО МОЛЮ, СКАЖИТЕ КАК РЕШАТЬ, ПОЖАЛУЙСТА, ЖЕЛАТЕЛЬНО С ПОДРОБНЫМ РЕШЕНИЕМ!!!
9 КЛАСС


Информатика (26 баллов) | 34 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Сначала задача должна быть решена геометрически. Очевидно, что круг войдет в прямоугольник если его диаметр D будет меньше, чем меньшая из сторон этого прямоугольника min(a,b). Вот и все решение.

По этому решению составляем алгоритм:
1. Ввести a, b, D
2. Найти m - минимум (a,b)
3. Если D4. Завершить работу.

Осталось написать программу.

1. Современное решение

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,d):=ReadReal3('Введите через пробел a,b,D:');
  var m:=Min(a,b);
  if D  else Writeln('Не войдет')
end.

Пример
Введите через пробел a,b,D: 14.5 11 10.6
Войдет

2. "Школьный" вариант - так писали наши отцы и деды

var
  a,b,D,m:real;

begin
  Write('Введите через пробел a,b,D: ');
  Read(a,b,d);
  if a  else m:=b;
  if D  else Writeln('Не войдет')
end.

(150k баллов)
0 голосов

Var a,b,D:integer;
begin
readln(a,b);
readln(D);
if (D<=a) and (D<=b) then writeln('YES')<br>else writeln('NO');                          
end.

(3.4k баллов)