Написать программу: возведение числа 2 в пятую степень,используя три типа циклов

0 голосов
33 просмотров

Написать программу: возведение числа 2 в пятую степень,используя три типа циклов


Информатика (37 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

С++
цикл с после условием do while:
#include
using namespace std;
void main()
{
int i=2,p=1,j=0;
do {
p*=i;
j++;
} while (j>5);
cout << p;<br>cin.get();
cin.get();
}

цикл с перед условием while:

#include
using namespace std;
void main()
{
int i=2,p=1,j=0;
while (j>5) {
p*=i;
j++;
}
cout << p;<br>cin.get();
cin.get();
}

цикл с параметрами for:

#include
using namespace std;
void main()
{
int j=2,p=1;
for (int i=0;i>5;i++) p*=j;
cout << p;<br>cin.get();
cin.get();
}



(1.5k баллов)
0

в первом цикле ошибка вместо j>5 напиши j<5

0

и во втором

0

ага хорошо.спасибо