Информатика.Паскаль.Задача.Известны координаты вершин A,B,C треугольника.Составить...

0 голосов
51 просмотров

Информатика.Паскаль.Задача.Известны координаты вершин A,B,C треугольника.Составить программу в паскале,вычисляющую площадь этого треугольника.Где:xa=2,ya=1,xb=6,yb=5,xc=10,yc=1


Информатика (23 баллов) | 51 просмотров
0

program z;var a,b,c,d,e,r,t,y,u,s,p:real;begin writeln('Введите координаты (x;y) точки А'); readln(a,b); writeln('Введите координаты (x;y) точки B'); readln(c,d); writeln('Введите координаты (x;y) точки C'); readln(e,r); t:=sqrt(sqr(a-c)+sqr(b-d)); y:=sqrt(sqr(a-e)+sqr(b-r)); u:=sqrt(sqr(c-e)+sqr(d-r)); p:=(t+y+u)/2; s:=sqrt(p*(p-t)*(p-y)*(p-u)); writeln('Площадь треугольника = ',s:5:2);end.

0

люблю запутанные программы

Дан 1 ответ
0 голосов

Var xa,ya,xb,yb,xc,yc,S:real;
begin
readln(
xa,ya,xb,yb,xc,yc);
S:=abs(((xb-xa)*(yc-ya)-(xc-xa)*(yb-ya))/2);
writeln(s);
readln;
end.

На паскале проверил, все отлично работает!:)

(435 баллов)
0

у меня не идет программа на паскаль!((((