Написать программу в Паскале,выводящую ** экран: 0 1 1 1 1 0 0 1 1 1 0 0 0 1 1 0 0 0 0 1...

0 голосов
38 просмотров

Написать программу в Паскале,выводящую на экран:
0 1 1 1 1
0 0 1 1 1
0 0 0 1 1
0 0 0 0 1
0 0 0 0 0
Используя оператор div и цикл в цикле


Информатика | 38 просмотров
Дан 1 ответ
0 голосов

program HelloWorld;

var res,i,z: integer;

begin

   for i:=4 downto 0 do

   begin

      for z:=5 downto 1 do

      begin

         res := 0;

         if i div z > 0 then res := 1;

         write(res);

         write(' ');

      end;

      writeln('');

    end;

end.

(6.5k баллов)