Помогите написать программу к задаче (верхняя). Использовать циклы.

0 голосов
24 просмотров

Помогите написать программу к задаче (верхняя). Использовать циклы.


image

Информатика (12 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var k:= ReadInteger('k =');
var (a,b) :=(1,1);
for var i := 3 to k do
  (a,b):= (b,a+b);
Writeln('a) ', b);
(a,b) :=(1,1);
var sum:= 2;
var n:= ReadInteger('n =');
Write('б) 1, 1');
for var i:= 3 to n do
    begin
      (a,b):= (b,a+b);
      Write(', ', b);
      sum+= b;
    end;
Writeln;
Writeln('в) ', sum.IsEven?'YES':'NO');
end.

(8.8k баллов)
0

прошу прощения, не заметил"использовать циклы" сейчас исправлю