Работа с системой программирования ** языке Паскаль.Составьте программу для вывода **...

0 голосов
80 просмотров
Работа с системой программирования на языке Паскаль.

Составьте программу для вывода на экран простых чисел, определяемых по формуле PRCHISLO = n^2-n+41 , где n = 1, 2, 3, ..., 40. Вывод чисел реализуйте в строку, через пробел.

Информатика (19 баллов) | 80 просмотров
Дан 1 ответ
0 голосов

Var n, fom, fin: integer;egin
begin

n := StrToInt(Edit 1. Text) ;
fom := Power(n, 2)-n+41;
fin := IntToStr(fom) ;
if (n >= 1) or (n <= 40) then Edit 2. Text := fin;<br>else Edit 2. Text := 'Значение не подоходит' ;

end;
(632 баллов)
0

fom замени prchuslo, не заметил

0

уже подругому сделала

0

var PRCHISLO, n: integer;
begin
for n:=1 to 40 do
begin
PRCHISLO:=sqr(n)-n+41;
write (' ',PRCHISLO);
end;
end.