Составить блок схему и написать программу ** турбо Паскале . Вычеслить...

0 голосов
62 просмотров

Составить блок схему и написать программу на турбо Паскале . Вычеслить s=1/2[max(a,b,c)+min(a,b,c)]

1) a=8; b=3; c=-2;

2)a=1; b=4; c=16;


Информатика (22 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

1)
var s,a,b,c:real;
begin
a:=8; b:=3; c:=-2;
s:= 1/2[max(a,b,c)+min(a,b,c)];
end.
2)
var s,a,b,c:real;
begin
a:=1; b:=4; c:=16;
s:= 1/2[max(a,b,c)+min(a,b,c)];
end.

(454 баллов)
0

uses crt;
var a,b,c,max,min:integer; s:real;
Begin
clrscr;
Write('a='); readln(a);
Write('b='); readln(b);
Write('c='); readln(c);
max:=a;
If max>b then max:=b;
if max>c then max:=c;
min:=a;
if min if min s:=(1/2)*(max+min);
Writeln('s=',s);
writeln;
End.

0

конечно красивей было бы через функцию сделать, но сори, давно не писал в паскале ничего!

0

кстати если вы вообще не в теме! переменный a,b,c сдесь вводится с клавиатуры, так что можете задать любые значения чтобы проверить правильность решения(разумеется в пределах допустимых типов)!!

0

Один хрен числа заданы)

0

s:= 1/2[max(a,b,c)+min(a,b,c)]; но эту строчку ты не правильно написал! вроде бы нету стандартной функции в паскале max и min! их нужно самому прописывать! либо через ветвление, как сделать, как я!

0

s:= 1/2[max(a,b,c)+min(a,b,c)]; их сам определяешь , но необходимо наличие ветвления

0

Нас учили что есть, но записал её, да, неправильно. Забывать уже начал) Max(a,b,c: integer): integer; И Min(a,b,c: integer): integer;

0

1/2[max(a,b,c)+min(a,b,c)] задание поставлено именно так