Составьте программу выводящую ** экран числа от 1 до 30 которые делятся без остаткак ** и...

0 голосов
94 просмотров

Составьте программу выводящую на экран числа от 1 до 30 которые делятся без остаткак на и на 3 но не делятся на 4


Информатика (31 баллов) | 94 просмотров
0

на 3 и на что?

0

и на 2

Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,n,i:integer;
begin
  writeln('На что должно делиться (2 числа через пробел) =>');
  readln(a,b); {делится на а и b  но не делится на c}
  writeln('На что не должно делиться (1 число) =>');
  readln(c);
  writeln('Верхняя граница(1 число) =>');
  readln(n);

  for i:= 1 to n do
   if (i mod a = 0) and (i mod b = 0) and (i mod c <> 0) then
       writeln(i);
end.


var i:integer;
begin
  for i:= 1 to 30 do
   if (i mod 2 = 0) and (i mod 3 = 0) and (i mod 4 <> 0) then
       writeln(i);
end

2)
var i:integer;
begin
 
  for i:= 50 downto 1 do
   if (i mod 2 <> 0) then
       writeln(i);
end.



(53.1k баллов)
0

9*9=81

0

9=81

0

8*8=64

0

7*7=49

0

6*6=36

0

5*5=25

0

4*4=16

0

3*3=9

0

2*2=4

0

составьте программу выводящую на экран фрагмент таблицы умножения: 1*1=1

0 голосов

1)
var
i: Integer;
begin
for i:=1 to 30 do
if ((i mod 2) = 0) and ((i mod 3) = 0) and ((i mod 4) <> 0) then
WriteLn(i);
end.

(57 баллов)
0

вот

0

задай еще вопрос на эту задачу я напишу все как надо здесь не получается!

0

это все в одну строку получается так как я там мог скидываться с одной строки на другую а здесь не получится

0

эта кратко а можно так же с объснением как и в первой задаче?

0

3) var i: Integer; begin for i := 50 downto 1 do if (i and 1) = 1 then {либо (i mod 2)=1, либо Odd(i)} WriteLn(i); end.

0

как?

0

а можно полную задачу

0

вот

0

3) var i: Integer; begin for i := 50 downto 1 do if (i and 1) = 1 then {либо (i mod 2)=1, либо Odd(i)} WriteLn(i); end.

0

все задала