Составьте программу ** языке паскальи так, вопрос по Паскалю, сие не найти в интернете...

0 голосов
62 просмотров

Составьте программу на языке паскаль
и так, вопрос по Паскалю, сие не найти в интернете (ну по крайней мере мне)
вопрос:
Как оператор case заключить в case. Самое главное чтобы можно было сделать программу которая могла работать так:
»выберите раздел
»1-физика
»2-геометрия
»3-алгебра
1
»вы выбрали физику
»выберите действие
»1-узнать скорость
»2-узнать путь
1
»введите время пути в часах
И так далее там.

Если нужен пример кода то вот, но он не рабочий:
var
v,g,a,f:char;
time:real;
lenght:real;
speed:real;
begin
writeln('Выберите раздел:');
writeln('1-физика');
writeln('2-геометрия');
writeln('3-алгебра');
writeln('Ваш выбор: '); readln(v);
case v of
'1' begin
writeln('Выберите действие');
writeln('1-узнать скорость');
writeln('2-узнать путь');
write('Ваш выбор: '); readln(f);
case f of
'1': begin
writeln('Введите время пути в часах');
readln(time);
writeln('Введите длину пути в киллометрах ');
readln(lenght);
speed:=lenght/time;
writeln('Скорость=', speed:5:1,'км/ч')
end;
'2': begin
writeln('Введите скорость движения в км/ч');
readln(speed);
writeln('Введите время пути в часах');
readln(time);
lenght:=speed*time;
writeln('Путь=', lenght:5:1,'км');
end else writeln('Ощибка, такого пункта нет!');
end;
end;
end.


Информатика (61 баллов) | 62 просмотров
0

и что значит я не показал пример кода? Вон он в .txt формате как прикреплённый файл. Ты краб.

Дан 1 ответ
0 голосов
Правильный ответ

1) тут не поставил PROGRAM имя; var
2) case v of
"1" тут не поставил доветочие
3) else writeln(); тут не поставил end; один штуку, который закончит начала case f of
но ты краб его поставил до else я понял, а надо после, потому что else принадлежит не case v, а case f.

и всо он заработал вот код


Скачать вложение Текст (TXT)
(2.8k баллов)
0

спасибо за ответ, только вот program неособо обязателен)

0

если не сложно, можно показать пример кода?

0

уже не нужно, сам разобрался)

0

и что значит я не показал пример кода? Вон он в .txt формате как прикреплённый файл. Ты краб.

0

хмм, в приложении не видно) Зайду через сайт