Нужно написать программу в паскале.Задание 23.Заранее спасибо

0 голосов
69 просмотров

Нужно написать программу в паскале.Задание 23.Заранее спасибо


image

Информатика (15 баллов) | 69 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var x,y,z:real;
begin
readln(x);
if x>=0 then z:=4*x else z:=x*x*x;
writeln('z = ',z:6:4);
if z>=0 then y:=cos(x)/sin(x) else y:=sin(x)/cos(x);
writeln('y = ',y:6:4);
end.

Пример:
1.5
z = 6.0000
y = 0.0709

(194k баллов)
0 голосов

Program mr_zerkalka;
uses crt;
var y,c,t,g,z,x:integer;
begin
wrtiteln('x=');
readln(x);
if x=>0 then
z:=4*x;
if x<0 then<br>z:=sqr(x);
wrtiteln('c=,t=,g=');
readln(c,t,g);
if z=>0 then
y:=c*t*g*z;
if z<0 then<br>y:=t*g*z;
writeln('z=',z);
writeln('y=',y);
end.















(262 баллов)
0

Понятия не имею, ее нужно перевести в вид программы шобы на паскале работало. Если поможешь, то необъятная благодарность тебе.

0

все

0

Free Pascal Compiler version 3.0.2 [2017/03/27] for x86_64
Copyright (c) 1993-2017 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling main.pas
main.pas(5,1) Error: Identifier not found "wrtiteln"
main.pas(7,6) Error: Illegal expression
main.pas(7,7) Fatal: Syntax error, "THEN" expected but "ordinal const" found
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode

0

Написало ошибку какую-то

0

wrtiteln у меня ошибка в написании правильно writeln

0

но код рабочий уже проверил

0

спасибо