Помогите пожалуйста! Напишите эту программу ,но только с while. Напишите программу,...

0 голосов
69 просмотров

Помогите пожалуйста! Напишите эту программу ,но только с while.
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число минимальное число, оканчивающееся на 6.


Информатика (93 баллов) | 69 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,k,m,mn: integer;
begin
  write('n = ');  readln(n);
  mn:=30000;
  k:=0;
  while k  begin
    read(m);
    if (abs(m mod 10) = 6) and (m    k:=k+1;
  end;
  writeln(mn);
end.

n = 5
21 -26 18 -16 35
-26

(9.7k баллов)
0

спасибо, вы меня так выручили!!!

0

Пожалуйста.

0

можете ещё с одной прграммой помочь?

0

очень надо!

0

Вопрос задайте.

0

Помогите пожалуйста написать эту программу с while!
Напишите программу, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет ко­ли­че­ство чисел, крат­ных 3. Про­грам­ма по­лу­ча­ет на вход ко­ли­че­ство чисел в последовательности, а затем сами числа. В по­сле­до­ва­тель­но­сти все­гда име­ет­ся число, крат­ное 3. Ко­ли­че­ство чисел не пре­вы­ша­ет 100. Введённые числа не пре­вы­ша­ют 300. Про­грам­ма долж­на вы­ве­сти одно число — ко­ли­че­ство чисел, крат­ных 3.

0

я уже задала этот вопрос на сайте