Составьте программу с названием А[1..20] которая вводит числа рандомно и находит среднее...

0 голосов
68 просмотров

Составьте программу с названием А[1..20] которая вводит числа рандомно и находит среднее арифметическое чётных чисел и среднее арифметическое индексов нечётных чисел.


Информатика (26 баллов) | 68 просмотров
0

с названием A[1..20] ?

0

А в промежутке от 1 до 20. Если бы вы разбирались в информатике, поняли бы

Дан 1 ответ
0 голосов

{
 PascalABC.NET, но все кроме writeln() должно работать и на TurboPascal.
 вводит числа рандомно и находит среднее арифметическое
 чётных чисел и среднее арифметическое индексов нечётных чисел.
}

PROGRAM A4;
const
    num = 16;
var
    MT:array [1..num] of byte;// массив чисел
    i,j:byte;// счетчики
    even_sum:integer;// сумма четных
    even_num:byte;// количество четных

    indx_sum:integer;// сумма нечетных индексов
    indx_num:byte;// количество нечетных индексов
    
BEGIN
  // условно ввели набор чисел
  randomize();
  for i:=1 to num do
    MT[i] := random(256);
  writeln('Начальный массив ', num ,' случайных чисел');
  writeln(MT);
 
  // сам алгоритм
  even_sum := 0;
  even_num := 0;
 
  indx_sum := 0;
  indx_num := 0;
 
  writeln(' ');
  write('Четные числа: ');

  for i:=1 to num do begin
    if not odd(MT[i]) then begin
      write(MT[i], ' ');
      even_sum := even_sum + MT[i];
      even_num := even_num + 1;
    end;
    if odd(i) then begin
      indx_sum := indx_sum + i;
      indx_num := indx_num + 1;
    end;
  end;
 
  writeln(' ');
  writeln('Количество четных чисел ', even_num);
  writeln('Среднее арифметическое четных чисел = ',
           even_sum, '/', even_num , ' = ', even_sum/even_num );
 
  writeln(' ');
  writeln('Количество нечетных индексов нечётных чисел ', indx_num);
  writeln('Среднее арифметическое индексов нечётных чисел ',
           indx_sum, '/', indx_num, ' = ', indx_sum/indx_num);
END.


image
(10.8k баллов)
0

Среднее арифметическое всегда равно количеству. Но оставил для наглядности

0

Речь идет про индексы нечетных чисел

0

Шедевр))))

0

Да ну. 6 или 7 класс общеобразовательной школы