Написать программу в Pascal. Дана матрица, нужно вычислить среднее значение чисел в...

0 голосов
26 просмотров

Написать программу в Pascal.
Дана матрица, нужно вычислить среднее значение чисел в каждом столбце матрицы


Информатика (67 баллов) | 26 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
a:array [1..10,1..10] of integer;
i,j:byte;
sum:real;
begin
randomize();
for j:=1 to 10 do
begin
for i:=1 to 10 do
begin
a[i,j]:=random(21);
end;
end;
for j:=1 to 10 do
begin
for i:=1 to 10 do
begin
write(' ',a[i,j]);
end;
writeln();
end;
writeln();
for j:=1 to 10 do
begin
for i:=1 to 10 do
begin
sum:=sum+a[j,i];
end;
writeln(j,'-ый столбец: ',sum/10);
sum:=0;
end;
end.
Матрица 10×10 заполняется случайными числами от 0 до 20 и выводится средняя сумма элементов в столбце.

(4.3k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1633 от 10.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*n*'-');
  Writeln('Средние значения по столбцам');
  a.Cols.Select(col->col.Average).Println
end.

Пример
Количество строк и столбцов в матрице: 6 7
*** Исходная матрица ***
 -70  66 -81  -2  42  22  -7
 -42   4 -27  32   6 -38 -81
 -22 -60 -65 -26 -87   2 -49
 -59 -48  -5 -11  38 -27  98
 -94 -47  86 -11 -13 -92 -43
 -92  89 -58  37  20 -14 -45
----------------------------
Средние значения по столбцам
-63.1666666666667 0.666666666666667 -25 3.16666666666667 1 -24.5 -21.1666666666667
(150k баллов)