СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!!Составить программу, которая проверяет является...

0 голосов
29 просмотров

СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!!Составить программу, которая проверяет является ли билет счастливым. В билете 6 цифр.
8 класс!!!


Информатика (47 баллов) | 29 просмотров
0

Что значит "счастливым"?

0

Счастливым считается полученный в общественном транспорте билет, в шестизначном номере которого сумма первых трёх цифр совпадает с суммой трёх последних

0

Ну так и надо писать, клоун.

0

ну мне казалось, что про это все знают просто

0

Да, знал, когда мне лет 6 было. Как-то забылось.

Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadString();
write(a.SkipLast(3).Select(x->x.ToDigit()).Sum()=a.Skip(3).Select(x->x.ToDigit()).Sum());
end.

(149k баллов)
0 голосов

Var
a,sum1,sum2,i:longint;
begin
Readln(a);
for i:= 1 to 3 do
  begin
    sum1 := sum1 + a mod 10;
    a:= a div 10;
  end;
for i:= 1 to 3 do
  begin
    sum2 := sum2 + a mod 10;
    a:= a div 10;
  end;  
if (sum1 = sum2) then Writeln('YES')
  else Writeln('NO');
end.

Пример:
123321
YES


(8.8k баллов)