Помогите написать программу в Паскале

0 голосов
45 просмотров

Помогите
написать программу в Паскале


Информатика (55 баллов) | 45 просмотров
0

Нужно написать программу, рассчитывающую эти значения и выводящую их на экран? И значения присваивать или вводить с клавиатуры?

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,x,c):=(10.2,9.2,2.2,0.5);
  var f:=Ln(a+x*x)+Sqr(Sin(x/b));
  var z:=Exp(-c*x)*(x+sqrt(x+a))/(x-Sqrt(Abs(x-b)));
  Writeln('f=',f,', z=',z)
end.

Результат
f=2.76681498092073, z=-4.27250886022099
(150k баллов)