Помогите, пожалуйста, 20 баллов нужно написать программу ** данную задачу в Паскале:...

0 голосов
48 просмотров

Помогите, пожалуйста, 20 баллов
нужно написать программу на данную задачу в Паскале:
Найти сумму всех чисел вводимых пользователем от -20 до 20.
вот начало программы:
var a,s: integer;
begin
read(a);
s:0;
while a>0 do
begin
S:=S+a
read(a);
end;
write(S);
end.
нужно доделать и записать комментарии к программе


Информатика (336 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Program cikl;
uses crt;
var x,y:integer;
begin
write('веди нужное число');
read(x);
for y:=-25 to x do
write(' ',y);
inc(y);
end.
это сгадится

(26 баллов)