Pascal !!! Помогите составить программу которую выводит вот такую штуку,т.е.:...

0 голосов
48 просмотров

Pascal !!!
Помогите составить программу которую выводит вот такую штуку,т.е.:
1)S=2+4+6...+20
2)S=1+2+3...+20


Информатика (14 баллов) | 48 просмотров
Дано ответов: 2
0 голосов

Решение для задач ниже в комментарии

(1.7k баллов)
0

ДЛя первой

0

--------------------------

0

program HelloWorld;

var

i : integer;

begin

write('s = ');

for i:=1 to 20 do
if (i mod 2 = 0) and (i<>20)
then write(i,' + ')
else
if i=20
then write (i);
end.

0

---------------------------------------

0

ля второй

0

-----------------------------------------

0

program HelloWorld;

var

i : integer;

begin

write('s = ');

for i:=1 to 20 do
if (i mod 2 = 1) and (i<>20)
then write(i,' + ')
else
if i=20
then write (i);
end.

0 голосов

Var
  i,s:integer;

begin
  Write('S=2');
  i:=2;
  S:=i;
  while i<20 do begin<br>    i:=i+2;
    Write('+',i);
    s:=s+i
    end;
  Writeln('=',s)
end.

Результат
S=2+4+6+8+10+12+14+16+18+20=110

-------------------------

var
  i,s:integer;

begin
  Write('S=1');
  i:=1;
  S:=i;
  while i<20 do begin<br>    i:=i+1;
    Write('+',i);
    s:=s+i
    end;
  Writeln('=',s)
end.

Результат
S=1+2+3+4+5+6+7+8+9+10+11+12+13+14+15+16+17+18+19+20=210

(142k баллов)