Разработать программу Java, меняющую местами первый и последний четный элементы...

0 голосов
98 просмотров

Разработать программу Java, меняющую местами первый и последний четный элементы одномерного массива.


Информатика (152 баллов) | 98 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Package main;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
    public static BufferedReader READER = new BufferedReader(new InputStreamReader(System.in));
    public static void main(String[] args) throws IOException {
        int N = Integer.parseInt(READER.readLine());
        int[] array = new int[N];
        for(int i = 0; i < array.length; ++i)
            array[i] = Integer.parseInt(READER.readLine());
        Main.function(array);
        for(int i = 0; i < array.length; ++i)
            System.out.println(array[i]);
    }
    public static void function(int[] array) {
        int first=0, last=0, temp;
        for(int i = 0; i < array.length; ++i)
        if(array[i] % 2 == 0) {
            first = i;
            break;
        }
        for(int i = array.length - 1; i > 0; --i)
        if(array[i] % 2 == 0) {
            last = i;
            break;
        }
        temp = array[first];
        array[first] = array[last];
        array[last] = temp;
    }
}

(1.1k баллов)
0

спасибо огромное)

0

"больше ведь к этому вопросу ничего не требуется?)". На самом деле это не полная программа. Просто я не знаю откуда вы берёте данные. Из стандартного потока или из файла? А так нужно ещё дописать главный класс.

0

данные забиваются вручную, значит скорее всего из файла)

0

нужно уточнить бы

0

Скорее всего из стандартного потока ввода. Сейчас допишу.

0

хорошо

0

Всё. Формат ввода: сначала ввести количество чисел в массиве, затем сами числа. После ввода будет произведена замена и выведен результат.

0

Пример: 3 42 53 14

0

хорошо, понятно)

0

а сможете пожалуйста тот вопрос тоже?