Задан массив A[1..17]. Составьте программу, которая выводит индексы тех элементов,...

0 голосов
93 просмотров

Задан массив A[1..17]. Составьте программу, которая выводит индексы тех элементов, значения которых равны нулю.


Информатика (21 баллов) | 93 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
a:array[1..17] of integer;
i:integer;
begin
  for i:= 1 to 17 do
   begin
    read(a[i]);
    if a[i] = 0 then
      Write(i, ' ');
   end;
end.

пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11

(8.8k баллов)
0

Благодарствую!

0 голосов
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(17,-5,5); a.Println;
  var s:=a.IndexesOf(t->t=0);
  if s.Count>0 then s.Select(t->t+1).Println
  else Writeln('нет нулей')
end.

Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
(142k баллов)
0

Спасибо большое друг!

0

Пожалуйста