Даров ребят, помогите решить задачу для паскаля

0 голосов
80 просмотров

Даров ребят, помогите решить задачу для паскаля


Информатика | 80 просмотров
0

Давай условие

0

Ща

0

Проверьте, есть ли среди данных N чисел нули.Входные данныеВводится число N, а затем N чисел.Выходные данныеВыведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

Дан 1 ответ
0 голосов

Var n,i,a,b,c,d:longint;beginreadln (n);for i:=1 to n dobeginread (c);if c=0 then b:=b+1;end;if b>0 then write ('YES') elsewrite ('NO');end.

(347 баллов)
0

Давай.

0

Входные данные
Вводятся целые числа a и b. Гарантируется, что a не превосходит b.

Выходные данные
Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Если таких чисел нет, то ничего выводить не нужно.

0

Ага, сейчас минутку.

0

var a, b, i: longint;
begin
read(a,b);
for i:= trunc(sqrt(a)+1-1e-9) to trunc(sqrt(b)) do
writeln(i*i);
end.

0

Должна работать.

0

Емае по легче можешь сделать?

0

Мы пока ток 8 кл, trunc и sqrt ещё не знаю

0

Ну смотри.

0

sqrt это корень квадратный, а trunc округление.

0

Ааааааааааа пасиб