Помогите составить программу в Pascal , что в белой рамочке

0 голосов
19 просмотров

Помогите составить программу в Pascal , что в белой рамочке


image

Информатика (20 баллов) | 19 просмотров
0

Сколько всего может быть чисел?

Дан 1 ответ
0 голосов

Program zadacha; Var mas:array [1..100] of integer;     min,max,i,n:integer;begin Writeln ('Введите количество чисел'); Readln (n); For i:=1 to n do begin writeln ('Введите ',i,' число');                        Readln (mas[i]);                  end; Writeln ('Полученные числа '); for i:=1 to n do writeln (mas[i]);Max:=mas[i];For i:=2 to n do  if mas[i]>max then max:=mas[i];writeln ('Максимальное число ',max);min:=mas[i];For i:=1 to n do if mas[i]<min then min:=mas[i];writeln ('Минимальное число ',min);end.

(63 баллов)
0

Program zadacha;
Var mas:array [1..100] of integer;
min,max,i,n:integer;
begin
Writeln ('Введите количество чисел');
Readln (n);
For i:=1 to n do
begin
writeln ('Введите ',i,' число');
Readln (mas[i]);
end;
Writeln ('Полученные числа ');
for i:=1 to n do
writeln (mas[i]);
Max:=mas[i];
For i:=2 to n do
if mas[i]>max then max:=mas[i];
writeln ('Максимальное число ',max);
min:=mas[i];
For i:=1 to n do
if mas[i]writeln ('Минимальное число ',min);
end.