Напишите программу, пожалуй та

0 голосов
35 просмотров

Напишите программу, пожалуй та


image

Информатика (634 баллов) | 35 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

1)
Program n1;
var x,y,z: real;
begin
readln(x,y);
if x+y<0 then z:=0.8+x else if x+y>5 then z:=x*x+y*y+5 else z:=y*x;
write('z=',z);
end.
2)
Program n2;
var a,b: real;
begin
readln(a,b);
if a-b>0 then write('разность положительная') else
write('разность не положительная');
end.

(149k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите значение х и у через пробел:');
  var xy:=x+y;
  var z:real;
  if xy<0 then z:=0.8+x<br>  else
    if xy<=5 then z:=y*x<br>    else z:=x*x+y*y+5;
  Writeln('z=',z)
end.

begin
  var (x,y):=ReadReal2('Введите два числа через пробел:');
  if x-y>0 then Writeln('Их разность положительна')
  else Writeln('Их разность не положительна')
end.
(150k баллов)
0

у вас небольшая опечатка: не x-y>9, а x-y>0