Напишите программу, которая выводит ** экран все простые числа в диапазоне от 1 до числа,...

0 голосов
68 просмотров

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры


Информатика | 68 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Прости, что отвечаю через 2 часа, был не дома)

var 
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;

(114 баллов)
0

это какое

0

что какое?

0

ниче

0

а это правильно