Срочно и пожалуйста не нужно писать просто так, только программу. Массив из 8 элементов...

0 голосов
17 просмотров

Срочно и пожалуйста не нужно писать просто так, только программу. Массив из 8 элементов содержит оценки за четверть. Заполнение его организовать с клавиатуры. Написать программу, которая вычислит четвертную оценку и выведет ее на экран.

Для этого будет необходимо:

1. Найти сумму элементов массива.

2. Посчитать среднее арифметическое оценок – x.

3. Округлить х до отметки. Правило, как выставляются оценки за четверть:

0
2.5<=x<=3.49 отметка 3<br>
3.5<=x<=4.49 отметка 4<br>
4.5<=x<=5 отметка 5.<br>


Информатика (130 баллов) | 17 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
s, i: integer;
x:real;
mas: array [1..8] of integer;
begin
s:=0;
for i:=1 to 8 do
begin
readln (mas[i]);
s:=s+mas[i];
end;
x:=s/8;
If (x>0) and (x<2.49) then write ('2');<br> If (x>=2.5) and (x<=3.49) then write ('3');<br> If (x>=3.5) and (x<=4.49) then write ('4');<br> If (x>=4.5) and (x<=5) then write ('5');<br>end.

(484 баллов)