Помогите написать программу на c++
че за единица над k?
а блин 1/k :)
Если вы хотите, чтобы вам кто-нибудь ответил, пишите понятней. Лично я не очень-то понимаю вашу запись.
#include using namespace std; int main() { double sum = 0; double k = 1; cout << fixed;<br> cout.precision(10); for (k = 2; k <= 7; k++)<br> sum = sum + (1/k); k = 1; for (int i = 1; i <= 5; i++) <br> k = k * sum; cout << k << endl;<br> system("pause"); return 0; } Так сделано:
Спасибо большое за решение! Но можете пожалуйста обьяснить что за строка и зачем она нужна?) cout.precision(10);
А вся, она вроде нужна для отображение 10 элементов в ответе :D
Можно убрать строчки:
//cout << fixed;<br> //cout.precision(10); //cout << k << endl;
И написать: printf("%f5\n", k);
printf("%.5f\n", k); точнее.