Напишите программу, которая получает день и номер месяца, а выводит количество дней,...

0 голосов
217 просмотров

Напишите программу, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года. Считайте, что год невисокосный (365 дней). Учтите что слова "дней" может иметь также формы "день" и " дня "


Информатика (20 баллов) | 217 просмотров
Дан 1 ответ
0 голосов

Здесь нужно работать с case на мой взгляд, т.к надо еще изменять формы дня, если знаешь как работать с case, то можешь расписать все, смотри пример:
int den;
int nomer;
Console.WritrLine("Введите день");
den = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите номер месяца")
nomer = Convert.ToInt32(Console.ReadLine());
switch (den)
{
case 1:
Console.WriteLine("До нового года 364 дня");
break;
}
и так далее

(625 баллов)