Написать программу и составить блок-схему для вычисления всех значений функции...

0 голосов
143 просмотров

Написать программу и составить блок-схему для вычисления всех значений функции Z(x)=cos(2x)sin(x),если переменная х меняется в интервале [-5;5] с шагом hx=0.345


Информатика (34 баллов) | 143 просмотров
Дан 1 ответ
0 голосов

//Z(x)=cos(2x)sin(x),если переменная х меняется в интервале [-5;5] с шагом hx=0.345

PROGRAM B07;
CONST
    min=-5;
    max=5;
    hx=0.345;
VAR
    x,z,k:real;

BEGIN
  x:=min;
 
  while (x<=max) do begin<br>    writeln ('x=', x:6:3, ' ', cos(2*x)*sin(x), ' ' );
    x:=x+hx;
  end;
 
END.


image
(10.8k баллов)