Часть 2. Составьте программу

0 голосов
38 просмотров

Часть 2. Составьте программу


image

Информатика (15 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  if n<=1 then begin<br>    Writeln('n должно быть больше 1');
    exit
    end;
  var (max,steps):=(n,0);
  Print(n);
  while n<>1 do begin
    if n.IsEven then n:=n div 2
    else n:=n*3+1;
    Print(n);
    if n>max then max:=n;
    steps+=1
    end;
  Writeln(NewLine,'Наибольшее число в последовательности ',max);
  Writeln('Число шагов алгоритма ',steps)
end.

Пример
n= 1242
1242 621 1864 932 466 233 700 350 175 526 263 790 395 1186 593 1780 890 445 1336 668 334 167 502 251 754 377 1132 566 283 850 425 1276 638 319 958 479 1438 719 2158 1079 3238 1619 4858 2429 7288 3644 1822 911 2734 1367 4102 2051 6154 3077 9232 4616 2308 1154 577 1732 866 433 1300 650 325 976 488 244 122 61 184 92 46 23 70 35 106 53 160 80 40 20 10 5 16 8 4 2 1
Наибольшее число в последовательности 9232
Число шагов алгоритма 88
(150k баллов)