СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!! написать программу ** паскале которая печатает...

0 голосов
37 просмотров

СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!!
написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше


Информатика (47 баллов) | 37 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('Введите число').ToString();
var (d1,d4):=(a[1].ToDigit(),a[4].ToDigit());
writeln('первая: ',d1,'; четвертая: ',d4);
if d1>d4 then write ('больше ',d1) else if d1write('цифры равны: ',d1);
end.

(150k баллов)
0 голосов

Var
x:integer;
begin
Read(x);
Writeln(x div 1000, ' ', x mod 10);
if x div 1000 > x mod 10 then Writeln(x div 1000, ' - больше');
if x div 1000 < x mod 10 then Writeln(x mod 10, ' - больше');
if x div 1000 = x mod 10 then Writeln('Они равны');
end.

Пример:
1234
1 4
4 - больше


(8.8k баллов)