Информатика , 9 класс. Паскаль . Помогите пожалуйста решит. 2. В первый день ученик...

0 голосов
32 просмотров

Информатика , 9 класс. Паскаль . Помогите пожалуйста решит. 2. В первый день ученик выучил 3 английских слова, а в каждый следующий день – на 1 слово больше, чем в предыдущий. Составить программу для вычисления количества слов, выученных учеником за неделю.


Информатика (40 баллов) | 32 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Пусть в первый день ученик выучил k слов.
Тогда за n дней он выучит
\displaystyle S=\sum_{i=0}^{n-1}(k+i)=kn+\sum_{i=0}^{n-1}i=kn+\frac{0+n-1}{2}n=kn+ \frac{n(n-1)}{2}

Теперь можно написать программу. Известно, что k=3, n=7.
Ручной счет дает 3×7+6×7/2 = 21+21 = 42.

// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (k,n):=(3,7);
  Writeln(k*n+n*(n-1) div 2)
end.

Результат
42

Хорошая иллюстрация случая, когда для решения задачи компьютер не нужен. Так бывает, когда составители заданий думают тем, на чем сидят.

(150k баллов)
0 голосов

Var k,s,i:integer;
begin
k:=3;
s:=3;
for i:=2 to 7 do
 begin
 k:=k+1;
 s:=s+k;
 end;
writeln('Количество выученных слов = ',s);
end.

Результат:
Количество выученных слов = 42

(194k баллов)