Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает:...

0 голосов
38 просмотров

Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает: прямоугольник, или треугольник. После того, как пользователь выберет фигуру, программа интересуется, что он хочет найти для данной фигуры: площадь или периметр. После того, как пользователь выберет величину, которую хочет посчитать, программа запрашивает данные для подсчета величины данной фигуры.
на С++


Информатика (1.0k баллов) | 38 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;

int main()
{
    int n, k, a, b, c, h;
    setlocale(LC_ALL, "rus");
    cout << "Выберите фигуру \n";<br>    cout << "1 - Треугольник \n";<br>    cout << "2 - Прямоугольник \n";<br>    cin >> n;
    cout << "Площадь или периметр \n";<br>    cout << "1 - Площадь \n";<br>    cout << "2 - Периметр \n";<br>    cin >> k;
    if (n == 1) {
        if (k == 1) {
            cout << "Введите длину основания: ";<br>            cin >> b;
            cout << "Введите высоту: ";<br>            cin >> h;
            cout << "S = " << b * h * 0.5 << '\n';<br>        }
        if (k == 2) {
            cout << "Введите 3 стороны:" << '\n' << "a: ";<br>            cin >> a;
            cout << '\n';<br>            cout << "b:";<br>            cin >> b;
            cout << "/nc: ";<br>            cin >> c;
            cout << "P = " << a + b + c << '\n';<br>        }
    }
    if (n == 2) {
        if (k == 1) {
            cout << "Введите длину: ";<br>            cin >> a;
            cout << "Введите ширину: ";<br>            cin >> b;
            cout << "S = " << a * b << '\n';<br>        }
        if (k == 2) {
             cout << "Введите длину";<br>            cin >> a;
            cout << "Введите ширину: ";<br>            cin >> b;
            cout << "P = " << 2 * (a + b) << '\n';<br>        }
    }
}



(3.4k баллов)