Написать программу, которая переводит из двоичной в десятичную систему счисления ** С#...

0 голосов
36 просмотров

Написать программу, которая переводит из двоичной в десятичную систему счисления на С# или С.


Информатика (91 баллов) | 36 просмотров
0

блин, а на С++ можно ?

Дан 1 ответ
0 голосов
Правильный ответ

Using System;

public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i    if (s[i]=='1') n += d;
   d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}

Пример:
Введите двоичное число: 1110111
n = 119

(194k баллов)