Ниже записана программа. Получив ** вход число x , эта программа печатает два числа, L и...

0 голосов
136 просмотров

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

var x, L, M: integer;

begin

readln(x);

L:=0; M:=0;

while x > 0 do begin

L:= L + 1;

if x mod 2 = 0 then

M:= M + (x mod 10) div 2;

x:= x div 10;

end;

writeln(L); write(M);

end.


Информатика (19 баллов) | 136 просмотров
Дан 1 ответ
0 голосов

Ответ 842, потому что подходит.

(120 баллов)
0

не скажешь как получилось?))

0

L говорит о том, что должно быть 3 шага, так как увеличивается в цикле безусловно.

0

Спасибо за помощь!))

0

x говорит о том, что максимальное число может быть 999 (нацело делится 3 раза на 10), но там условие на чётность x, так что это должно быть чётное число каждый раз). А дальше подходящее для M подбирается легко.

0

ааа, понял. теперь доходчиво:-)