Написать программу ** паскале и сделать к нему блок схему16.Вычислить : y= lg (sin)...

0 голосов
30 просмотров

Написать программу на паскале и сделать к нему блок схему
16.Вычислить : y= lg (sin\frac{Pi}{x}) [-5,5]. H=0.01.


Информатика (418 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

// для x<0 выражение смысла не имеет<br>
PROGRAM B09;
CONST
    min=-5;
    max=5;
    hx=0.01;
VAR
    x:real;

BEGIN
  x:=min;
  while (x<=max) do begin<br>    writeln ('x=', x:6:3, ' ', log10( sin(Pi/x) ), ' ' );
    x:=x+hx;
  end;
END.


image
image
(10.8k баллов)