задача 1 Cоставить программу,которая позволяет ввести строку s,затем после каждой буквы...

0 голосов
35 просмотров

задача 1

Cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел.

задача 2

Составить программу,которая удаляет в строке S все буквы "о"


Информатика (28 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.

(8.2k баллов)
0

if (s[i]='о') or (s[i]='o') then а тут скобки обязательно надо?

0

Если оставлять or, то надо. Для char применять or нельзя, а скобки выдают логическое булевное значение true/false, и их уже можно объединять.