Составить программу, которая вычисляет, через сколько лет удвоится вклад в банке, если...

0 голосов
140 просмотров

Составить программу, которая вычисляет, через сколько лет удвоится вклад в банке, если начальная сумма S, процент годовых R.
В "PascalABC"


Информатика (236 баллов) | 140 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
s, r, k:real;
ans:integer;
begin
Read(s,r);
k:= s; ans:= 0;
While (k < 2 * s) do begin
  ans:= ans + 1;
  k:= k + k * (r/100);
end;
Writeln(ans);
end.

Примеры:
````````````````````
100 20
4
````````````````````
100 100
1

(8.8k баллов)
0

Аригато! Извини, случайно отметил лучшим не твоё решение, но плагиатчицу зарепортил.