Составить программу которая формирует массив из 12 случайных чисел от 0 до 40 и выводит...

0 голосов
43 просмотров

Составить программу которая формирует массив из 12 случайных чисел от 0 до 40 и выводит на экран чётные элементы массива/
СРОЧНО


Информатика (56 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

Var a: array[1..12] of integer;
    i: integer;
begin
   randomize;
   write('массив:  ');
   for i:=1 to 12 do
   begin
     a[i]:=random(40);
     write(a[i],' ');
   end;
   writeln;
   write('четные элементы:  ');  
   for i:=1 to 12 do 
   if (a[i]>0) and (a[i] mod 2 = 0) then write(a[i],' ');
end. 

массив:  10 27 38 8 25 22 31 13 27 14 12 11 
четные элементы:  10 38 8 22 14 12 


(9.7k баллов)
0

Спасибо Вам огромное,я очень благодарна.

0

Не за что.