Помогите пожалуйста!!! Задача ** Paskal Напишите программу, которая вычесляет среднюю...

0 голосов
38 просмотров

Помогите пожалуйста!!! Задача на Paskal

Напишите программу, которая вычесляет среднюю температуру воздуха за 10 дней, выведит на экран max и min значение температуры. Данные вводятся с клавиатуры.


Информатика (18 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Var A:array [1..10] of integer;
b,min,max,i:integer;
c:real;
begin
b:=0;
c:=0;
for i:=1 to 10 do readln(A[i]);
for i:=1 to 10 do b:=b+A[i];
c:=b/10;
min:=A[1];
max:=A[1];
for i:=1 to 10 do 
if A[i]for i:=1 to 10 do 
if A[i]>max then max:=A[i];
writeln(c);
writeln(min);
writeln(max);
end.             

(3.4k баллов)