Помогите с задачей по информатике прошу вас. Срочно. ** паскале или ** C++. Желательно...

0 голосов
65 просмотров

Помогите с задачей по информатике прошу вас. Срочно. На паскале или на C++. Желательно все-таки на паскале
Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt

Даны два числа A и B (0<=A,B<=100000). Напишите программу нахождения произведения числа А на все цифры числа В. Входной файл input.txt содержит два числа A и B. В выходной файл output.txt вывести одно число – произведение числа А на все цифры числа В.<br>
Ввод 3 33
Вывод 27


Информатика (225 баллов) | 65 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2;
  if b=0 then Writeln(0)
  else begin
    var p:int64:=a;
    while b>0 do begin
      p*=b mod 10;
      b:=b div 10
      end;
    Writeln(p)
    end
end.

Пример
2342 8945923
182113920
(150k баллов)
0

Спасибо

0 голосов

Var
a,b:int64;
Begin
Read(a, b);
 if b = 0 then Writeln(0)
  else begin
    While b > 0 do begin
      a:= a * (b mod 10);
      b:= b div 10;
    end;
Writeln(a);
end;
end.

(8.8k баллов)
0

....

0

fixed*

0

После такого стресса хочется пойти и выпить пару кружек чаю, сегодня ошибка на ошибке, просто шок....