Написать программу, которая выводит таблицу значений функции у = \х - 2| + |х + 1|....

0 голосов
192 просмотров

Написать программу, которая выводит таблицу значений функции у = \х - 2| + |х + 1|. Диапазон изменения аргумента - от -4 до 4, шаг приращения аргумента — 0,5.


Информатика (15 баллов) | 192 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var x:real;
begin
 x:=-4.5;
 writeln('x    y');
 for var i:=1 to 17 do
 begin
  x:=x+0.5;
  writeln(x,'    ',abs(x-2)+abs(x+1));
 end;
readln;
end.

Пример:
x  _  y
-4  _  9
-3.5  _  8
-3  _  7
-2.5  _  6
-2  _  5
-1.5  _  4
-1  _  3
-0.5  _  3
0  _  3
0.5  _  3
1  _  3
1.5  _  3
2  _  3
2.5  _  4
3  _  5
3.5  _  6
4  _  7

(5.8k баллов)
0

Fatal: Internal error 200611054

0

Fatal : Compilation aborted

0

хм..

0

А вы собственно где код тестили, случайно не Free Pascal?

0

да

0

А теперь, посмотрите где писал я

0

а мне нужно в этой программе , помогите

0

Сейчас исправлю

0

var x:real;
i:integer;
begin
x:=-4;
writeln('x y');
for i:=1 to 17 do
begin
writeln(x,' ',abs(x-2)+abs(x+1));
x:=x+0.5;
end;
end.

0

большое спасибо