Напишите программу, которая получает два целых числа (A и B) и находит их произведение,...

0 голосов
72 просмотров

Напишите программу, которая получает два целых числа (A и B) и находит их
произведение, не используя операцию умножения. Учтите, что числа могут быть
отрицательными.
Формат входных данных
В первой строке входных данных - два числа A и B (-10000 пробел
Формат выходных данных
Cтрока содержащее произведение чисел (см. пример вывода)
Пример
Входные данные Выходные данные
10 -15 10*(-15)=-150


Информатика (207 баллов) | 72 просмотров
Дан 1 ответ
0 голосов

#include   #include   #include #include   #include #include #include #include   #include   #include   using namespace std;
int main(){int a, b,f=0,f1=0,ans=0;cin >> a >> b;if (a < 0 ) f = 1;if (b < 0) f1 = 1;for (int i = 0; i < abs(b);i++){ ans += a;}if (f == 1 && f1 == 1) cout << abs(ans);else if (f == 1 || f1 == 1) cout << '-' << abs(ans); else cout << ans; return 0;}

(148 баллов)