Написать программу, которая бы по введенному номеру единицы измерения (1-дециметр,...

0 голосов
105 просмотров

Написать программу, которая бы по введенному номеру единицы измерения (1-дециметр, 2-километр, 3-метр, 4-миллиметр, 5-сантиметр) и длине отрезка L выдавала соответствующее значение длины отрезка в метрах.
Паскаль, использовать оператор условие If


Информатика (190 баллов) | 105 просмотров
Дан 1 ответ
0 голосов

//Pascal
var
  Ez: byte;
  z: real;
begin
  writeln('1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр');
  write('Введите номер единицы измерения: '); readln(Ez);
  write('Введите длинну: '); readln(z);
  if Ez = 1 then writeln(z/10, ' м');
  if Ez = 2 then writeln(z*1000, ' м');
  if Ez = 3 then writeln(z, ' м');
  if Ez = 4 then writeln(z/1000, ' м');
  if Ez = 5 then writeln(z/100, ' м');
  readln; 
end.  


image
(9.4k баллов)