Составьте программу,которая формирует массив из 11 случайных целых чисел от -10 до 5 и...

0 голосов
42 просмотров

Составьте программу,которая формирует массив из 11 случайных целых чисел от -10 до 5 и все положительные элементы возводит в квадрат


Информатика (14 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

Var
 i,s:integer;
a:array [1..11] of integer;
begin
 randomize;
 writeln('Chislo:   ','Chislo v kvadrate');
 for i:=1 to 11 do
  begin
   a[i]:=Random(15)-10;
   write(a[i]:4); writeln(sqr(a[i]):15);
  end;
end.

(5.8k баллов)